Extension Collection in MW 1.18

Use this forum to ask questions about how to do things in GuMax skin.

Extension Collection in MW 1.18

Postby helober » January 17th, 2012, 2:15 pm

I think I better start a new topic, since the one http://forum.paulgu.com/viewtopic.php?f=7&t=681 is about one year old and the solution offered there doesn't work any more.

Having upgraded to MW 1.18 and installed the extension:collection (also 1.18) I found a "heading" (like "toobox") saying "Print/export" but no clickable "subheading". The workaround that I discovered may not be very clean, but here it is

Step 1:
Edit the "Sidebar" by putting something like
Code: Select all
* Download
** http://mydomain.net/wiki/index.php?title=Special:Book&bookcmd=book_creator|Create book/file
underneath your existing Sidebar

Step 2:
In the collection.php file ../extensions/Collection/ I deleted this line
Code: Select all
$wgHooks['SkinBuildSidebar'][] = 'CollectionHooks::buildSidebar';

and that was it.

If anyone has a better solution, let me know
User avatar
helober
Rank 1
Rank 1
 
Posts: 7
Joined: September 13th, 2008, 4:30 am

Re: Extension Collection in MW 1.18

Postby Paul » January 17th, 2012, 8:20 pm

Thanks for sharing...

The old skin is not compatible with new mediawiki 1.17 and up version due to core update in mediwiki. You might want to get the latest GuMax and try it on new mediwiki.
User avatar
Paul
Development Team Leader
Development Team Leader
 
Posts: 1132
Joined: October 20th, 2007, 2:23 pm

Re: Extension Collection in MW 1.18

Postby helober » January 18th, 2012, 3:04 am

First, I have to apologize for having offered a "dirty trick" that does not function. It worked out for someone (person with a particular ID) who previously had used the extension collection, but for an anonymous user, who had not used it a "fatal error" (DNS error - server cannot be found) occurred. Maybe the whole post can be deleted?

As to the recommendation of upgrading: you have developed very nice skins, Paul. In addition, you've provided many hints on how to adapt the skins to specific needs. The groups for which I am maintaining the websites have very special expectations of what their pages should look like, where the navigation should be and which parts they want to be visible. Since I am just an odd volunteer and no expert at all, I'm afraid that it shall take me quite some time to adapt the parts in the "template.css" and other files to their "needs" (has to be done in 5 wikis). Nevertheless I agree that an upgrade seems to be the best idea.

And thanks again for all the great work you've done and are still doing.
User avatar
helober
Rank 1
Rank 1
 
Posts: 7
Joined: September 13th, 2008, 4:30 am

Re: Extension Collection in MW 1.18

Postby Paul » January 19th, 2012, 12:27 am

Don't worry about the post, people will understand through the whole posts.

The one of the big changes in new mediawiki is the head elements, which loads the core modules. These modules are required by wiki itself and extensions.

The new GuMax adapts these changes and will allow wiki and extension to work correctly.
User avatar
Paul
Development Team Leader
Development Team Leader
 
Posts: 1132
Joined: October 20th, 2007, 2:23 pm

Re: Extension Collection in MW 1.18

Postby alphyrome » January 14th, 2013, 4:51 am

I too had the same issue with Media Wiki new release, I tried the new version of GuMax and it worked correctly. I would suggest using the new GuMax to avoid the extension problem with new releases of media Wiki. Thank you for the help!
User avatar
alphyrome
Rank 0
Rank 0
 
Posts: 1
Joined: January 14th, 2013, 3:04 am

Re: Extension Collection in MW 1.18

Postby greatingz » March 21st, 2013, 9:35 am

What is the likelihood of running that command and then getting bogged down in issues of associated dependencies required but not installed on my server?
User avatar
greatingz
Rank 0
Rank 0
 
Posts: 1
Joined: March 21st, 2013, 9:33 am


Return to GuMax 'How Do I' Questions

Who is online

Users browsing this forum: Bing [Bot] and 3 guests

cron