Video player displays but doesn't play file -

If you are having problems with my MediaWiki Extensions, post here.

Video player displays but doesn't play file -

Postby Wturner » April 2nd, 2009, 10:56 am

Hi,

I added the flv player extension to our wiki . The player is displayed and looks great , but it won't play the flv file(s) I upload.


Here is a link to our sandbox where I have the player displayed as well as a link to an flv file.

http://www.wikiaudio.org/index.php?title=Sandbox

The player says " Video not found: images/9/96/Video.flv"

but when I go to that directory on the server the file is there.


Please help!

Thanx
User avatar
Wturner
Rank 2
Rank 2
 
Posts: 12
Joined: April 2nd, 2009, 10:52 am

Re: Video player displays but doesn't play file -

Postby Paul » April 2nd, 2009, 8:54 pm

The extension didn't get install properly...
User avatar
Paul
Development Team Leader
Development Team Leader
 
Posts: 1132
Joined: October 20th, 2007, 2:23 pm

Re: Video player displays but doesn't play file -

Postby Wturner » April 2nd, 2009, 11:30 pm

I followed the instructions to the tee.

I uploaded the file to the extensions directory and unzipped it.

Then I added the code to the localsettings.php file.

Do you have any idea what could have gone wrong?
User avatar
Wturner
Rank 2
Rank 2
 
Posts: 12
Joined: April 2nd, 2009, 10:52 am

Re: Video player displays but doesn't play file -

Postby Paul » April 2nd, 2009, 11:35 pm

Somehow, the extension didn't get loaded into page...
User avatar
Paul
Development Team Leader
Development Team Leader
 
Posts: 1132
Joined: October 20th, 2007, 2:23 pm

Re: Video player displays but doesn't play file -

Postby Wturner » April 3rd, 2009, 3:33 am

what version of mediawiki is the extension suppose to work with?

I am running :


MediaWiki 1.13.1
PHP 5.2.5 (cgi)
MySQL 4.1.22-standard-log
User avatar
Wturner
Rank 2
Rank 2
 
Posts: 12
Joined: April 2nd, 2009, 10:52 am

Re: Video player displays but doesn't play file -

Postby Wturner » April 3rd, 2009, 4:48 am

do you have any ideas for things I can do that might fix this?
User avatar
Wturner
Rank 2
Rank 2
 
Posts: 12
Joined: April 2nd, 2009, 10:52 am

Re: Video player displays but doesn't play file -

Postby Paul » April 3rd, 2009, 7:32 pm

Open the php file, try to change the variable below to a string and see what will happen.

Code: Select all
$playerID = mt_rand();
User avatar
Paul
Development Team Leader
Development Team Leader
 
Posts: 1132
Joined: October 20th, 2007, 2:23 pm

Re: Video player displays but doesn't play file -

Postby Wturner » April 4th, 2009, 5:14 am

could you elaborate on what php file you're referring to and what are the exact lines of code that are supposed to be added to the file
User avatar
Wturner
Rank 2
Rank 2
 
Posts: 12
Joined: April 2nd, 2009, 10:52 am

Re: Video player displays but doesn't play file -

Postby Paul » April 6th, 2009, 6:44 pm

there is only one php file in the package... :o
User avatar
Paul
Development Team Leader
Development Team Leader
 
Posts: 1132
Joined: October 20th, 2007, 2:23 pm

Re: Video player displays but doesn't play file -

Postby Wturner » April 6th, 2009, 7:23 pm

ok.

Could you elaborate on the exact lines of code?

I am relaying this to somebody who is trying to help me with this.
User avatar
Wturner
Rank 2
Rank 2
 
Posts: 12
Joined: April 2nd, 2009, 10:52 am

Next

Return to MediaWiki Extensions Troubleshooting and Problems

Who is online

Users browsing this forum: No registered users and 1 guest

cron