Newbie questions for Google Adsense Setup

If you are having problems with my MediaWiki Extensions, post here.

Newbie questions for Google Adsense Setup

Postby coolgreany » February 22nd, 2009, 10:13 am

First, thank you all for this forum.

I'm new to Wiki and Adsense and have Adsense working on some "normal" web pages at the moment. I'm converting my pages to Wiki format.

For some reason my ads are not showing up on the Wiki page - all I see is a blank box where the ad should be).

I'm using "<google>CH01</google> to disply the ad.

I can successfully see Google Search box using "<google></google> and Google You Tube using "<google>YouTube</google> (I asume youtube is non-revenue as I don't have it setup on my old pages?

I've placed the two extension files in a "GoogleAdSense" Folder under the "Extensions" folder nand have added info as follows to the php file (I've replaced the last few didgits with "xxx" for purposes of displying here):

$CLIENTID = "pub-486638311xxxxxxx"; // Your Client ID

$CHANNELS = array( // Your Channel ID
'CH01' => '608xxxxxxx',
'CH02' => 'xxxxxxxxxx',
'CH03' => 'xxxxxxxxxx'

What am I doing wrong?

Also, can I display an ad unit on the left side bar? If so how?

Thanks!
User avatar
coolgreany
Rank 1
Rank 1
 
Posts: 9
Joined: February 22nd, 2009, 10:01 am

Re: Newbie questions for Google Adsense Setup

Postby Paul » February 22nd, 2009, 1:55 pm

I assume you setup the Google Adsense properly in Google. If you just created it, then you need to wait a little bit.

After you added your Adsense in wiki, and if you are using Firefox, this could happen since both wiki and FF are caching the page.

Try to use IE to reload the page and see what will happen.
User avatar
Paul
Development Team Leader
Development Team Leader
 
Posts: 1132
Joined: October 20th, 2007, 2:23 pm

Re: Newbie questions for Google Adsense Setup

Postby coolgreany » February 23rd, 2009, 1:44 am

Yes, Paul, the ads have been running successfully for a year now on another web site.

I've double-checked my Channel IDs and even tried different channel IDs (that are working on other web site).
User avatar
coolgreany
Rank 1
Rank 1
 
Posts: 9
Joined: February 22nd, 2009, 10:01 am

Re: Newbie questions for Google Adsense Setup

Postby azahar » February 23rd, 2009, 1:00 pm

I am also having the same problem. YouTube and the search bar work perfectly, but not the CHxx as the OP.

I am using MediaWiki 1.12
User avatar
azahar
Rank 1
Rank 1
 
Posts: 7
Joined: February 23rd, 2009, 12:58 pm

Re: Newbie questions for Google Adsense Setup

Postby Paul » February 23rd, 2009, 6:33 pm

Wiki caches pages, please make sure clear the cache page in wiki.

Also you can try to edit the page that has extension, then just save it to see if the ads gets updated.
User avatar
Paul
Development Team Leader
Development Team Leader
 
Posts: 1132
Joined: October 20th, 2007, 2:23 pm

Re: Newbie questions for Google Adsense Setup

Postby azahar » February 24th, 2009, 4:36 am

1) Refreshed the cache, several times - no change.
2) Edited the page - no change.

I can confirm that my AdSense is correctly setup. I am using the following text in the wiki:

<google>CH01</google>

Any further ideas?
User avatar
azahar
Rank 1
Rank 1
 
Posts: 7
Joined: February 23rd, 2009, 12:58 pm

Re: Newbie questions for Google Adsense Setup

Postby Paul » February 24th, 2009, 6:45 pm

Are you test in IE or FF? There is a big difference between them...
User avatar
Paul
Development Team Leader
Development Team Leader
 
Posts: 1132
Joined: October 20th, 2007, 2:23 pm

Re: Newbie questions for Google Adsense Setup

Postby azahar » February 25th, 2009, 11:13 am

Am on a Mac, using Firefox and Safari. Neither wants to show the ad.
The YouTube and Search bar displays fine.
User avatar
azahar
Rank 1
Rank 1
 
Posts: 7
Joined: February 23rd, 2009, 12:58 pm

Re: Newbie questions for Google Adsense Setup

Postby coolgreany » February 25th, 2009, 3:54 pm

Same here - I have refreshed cache numerous times and also get same results in Firefox and IE.

I don't see any other variables other than the "Client ID" and "Channel ID"
User avatar
coolgreany
Rank 1
Rank 1
 
Posts: 9
Joined: February 22nd, 2009, 10:01 am

Re: Newbie questions for Google Adsense Setup

Postby Paul » February 25th, 2009, 6:31 pm

If you just setup the Adsense in Google, don't expect it appear right away, sometime, it takes days to show up ...
User avatar
Paul
Development Team Leader
Development Team Leader
 
Posts: 1132
Joined: October 20th, 2007, 2:23 pm

Next

Return to MediaWiki Extensions Troubleshooting and Problems

Who is online

Users browsing this forum: No registered users and 1 guest

cron